コードを読みやすくするために変数名を変えていいですか?

2021年2月3日
ユーザー

お世話になっております
自分はコードを見通すのが得意ではなく
自分で書いた変数名も、何を代入したものか覚えてなくて見返すと苦労することがよくあります、そこで。

ジャバスクリプトの変数名として、コードの読み通しをよくするために(htmlのどの要素を参照しているかをわかりやすくするために)
レッスンにあるように const colors = document.querySelectorAll('input');のところの変数名を

自分で変数名をかくとconst inputcolorsとするようなことで(inputを変数名に入れることでhtmlのinputをさしていることがわかります)
このように書くとhtmlの要素のどの部分を指しているのかがわかりやすいと思ったのですが
このような書き方は一般的ではないのでしょうか?また、推奨されない書き方なのでしょうか?

この回答を見るにはプレミアムサービスへの登録が必要です

プレミアムサービスとは?