User.count++; ではなく this.count++: や count++; でもよいのですか?

2021年6月2日
ユーザー

動画内で、クラスフィールドである、「count」へのアクセスは
クラス名.クラスフィールド名の「User.count++;」としていますが、
this.count++;」または「count++;」でも期待する動作になります。

これは単に動作には問題ないが、ソースコードを見たときにわかりやすいように、
クラスフィールドを使用していることを明示しているだけという理解でよろしいでしょうか。

この回答を見るにはプレミアムサービスへの登録が必要です

プレミアムサービスとは?